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Wio Lite MG126 sku: 102991186

Wio Lite MG126 is a cost-effective SAMD21 based development board with the on-board MG126 Bluetooth
Module. SAM D21 is an ARM Cortex-M0+ based microcontroller and the MG126 is a 2.4GHz single-mode
Bluetooth transceiver module. The same with Wio Lite W600, this board is also compatible with Arduino zero(
Used the same Arduino Core SAM D21) and has the same compatible form factor with Adafruit Feather series.

We break out the 3.3V I/O pins of SAM D21, SAM D21 chip has rich | / O resources, including 14 digital pins, 6
analog pins, 1 UART port, 1 12C port, and 1 ICSP port. More and more boards in Seeed use type C interfaces to

supply power and transmit data, so does the Wio Lite MG126. Meanwhile, there is a JST2.0 Li-Po battery port,
you can use 3.5V or 4.2V Li-Po battery to power this board.

Now, let's talk about the Bluetooth Core, the MG126. MG126 is a 2.4GHz BLE RF transceiver with software
configurable registers, embedded packet handling engine. It can work with ultra-low power. The Bluetooth air

data rate of MG126 is TMbps and MG126 can talks with Arduino core at the speed of 4Mbps via the SPI
interface.

Features

* Arduino Zero Compatible/ Adafruit Feather Compatible
® 24GHz ISM band operation with 2MHz channel spacing
* 1Mbps air data rate
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¢ Ultra-low power
Specification

Parameter Value

Main Controller

Microcontroller SAM D21

Digital 1/0 Pins 14

Analog Input Channels 6

DC Current per I/O Pin 40 mA

IO Input Voltage 33V

SRAM 32 KB

Flash 256 KB
Maximum CPU Frequency 48 MHz
Bluetooth

Bluetooth Core MG126
Frequency Band 2.4GHz ISM

Data Rate 1Mbps air data rate
Communication with MCU SPI (Max. 4Mbps)

) Programmable output power: -28 ~ +4 dBm
Transmitter .
without an external RF PA 20mA at 0dBm output power

Integrated channel filters
Receiver -85 dBm sensitivity
Programmable LNA gain

Antenna On-board PCB antenna

Max. Bluetooth Connect Distance 10 m

Others

USB Type C

Power Input Port .
JST2.0 Lipo Battery

. USB 5V
Operating Voltage
Battery 4.2V
Recoverable fuse Protection current 1A
Battery Charge Current 400 mA

Hardware Overview
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/PCB Antenna /

fe _/ SAMD21 |/0/
‘ 3.3V

SAMD21 1/0 :
3.3V

{SAMDZlE

SCK LED
TXLED

I I RX LED

JST 2.0 Battery
connecter

/ User Button / /Reset Button/

USB:Type C
Programming and 5V Power

ITip - The PCB antenna should not be shielded by metal when it is mounted, otherwise it will cause the
attenuation of the Bluetooth signal; - The positive and negative terminals of the battery are indicated on the
back of the module. It is strictly prohibited to reverse the positive and negative terminals of the battery.

Getting Started

Before the start, please download the nRF Connect app from Google/Apple Store. nRF Connect is
compatible with standard Bluetooth protocol functions, all examples are tested based on this app.

Hardware

Materials required

Wio Lite Mg126 x1
e Computer x1

USB typc cable x1
* Jumper x1
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ITip Some USB cables can only supply power and cannot transfer data. If you don't have a usb cable or don't
know if your usb cable can transmit data, you can check Seeed USB type C support USB 3.1.

Connect the Wio Lite MG126 to your computer via the USB cable.

Software

¢ Step 1. You need to Install an Arduino Software.

Download Arduino IDE

Launch the Arduino application
Double-click the Arduino application (arduino.exe) you have previously downloaded.

IlINote If the Arduino Software loads in a different language, you can change it in the preferences dialog. See
the Arduino Software (IDE) page for details.

* Step 2. Add the Wio Lite MG126 Board into Arduino IDE

Open your Arudino IDE, click on File > Preferences, and copy the following url to Additional Boards Manager
URLs

https://raw.githubusercontent.com/Seeed-
Studio/Seeed_Platform/master/package_seeeduino_boards_index.json
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https://www.seeedstudio.com/USB-Type-C-to-A-Cable-1Meter-p-4085.html
https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Guide/Environment#languages
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Click on Toos > Board > Board Manager. Search the board by name, just search the key word

Preferences *

Settings Network

Sketchbook location:

C:\Isers\looves\Documents\drduino | | Erowsze |
Editor language: |Engl:i.sh (English) V| (requires restart of Arduina)
Editer font size:

Interface scale: Automati.c (requires restart of Arduine)

Show verbose output during: [ | compilation [ upload

Compiler warnings:

Iisplay line numbers

[ Enable Code Folding

[A verify code after upload

[Juse external editor

[ Check for updates on startup

[] Update sketch files to new extension on save (.pde —» .ima)

[] Save when verifying or uploading

Additional Boards Manager URLs:

|.uhusercontent. comfloovee/Seeed Platform/master/package_seceduino_boards_index. json|

Mor e preferences can be edited directl}' in the file
C:\Users'\loovee\dpplata\Local \ArduinelS \preferences. txt \

(edit only vhen Arduine is net rmm:'lng)

and install the corresponding board.

9/27/2019

Type Al + ||| seeeduino_Wio_Lite_MG126 | |
Seeeduino_Wio_Lite_MG126 by Seeed Studio -
Boards included in this package:

Seeeduino_Wio_Lite_MG126.
Cnline help
Mare info \
Install
L

* Step 3. Select your board and port

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino. Selecting
the Wio Lite MG126.
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File Edit Sketch Tocols Help

Auto Forrmat Ctrl+T
Archive Sketch
readAngle Fix Encoding & Reload
#include <Wir Serial Monitor Ctrl+Shift+M
:i:;izd;;ii; Serial Plotter Ctrl=ShiftL
fdeErne SER WiFi101 Firmware Updater
#define 5Y5
Bt M;E! Board: "Seeeduino Wio lite MG126" E A
:ziz; so  Port:"COME2 (Seeeduino Wio lite MG126)" i Arduino NG or older
e Get Board Info Arduino Robot Control
Arduino Robot Motor
AMS 5600 ams5 Programmer: "AVRISP midl" ‘ Arduino Gemma
Burn Bootloader Adafruit Circuit Playground

int ang, lang = U7 . .
' Arduino Yian Mini

void setup() Arduino Industrial 101

{ Linino One
SERIAL.b=gin(115200) ;7 : —
.glr{ : Arduine Uno WiFi
Wire.begin();
SERIAL.Drintln (" sosnsniiiisiriiriirnbrsisrsdins ") ; Arduino ARM (32-bits) Boards
if (ams5600.detectMagnec() == 0 ){ Arduino Due (Programming Port)

while {1} - :

S E s e e i =1 1) Arduino Due (Native USE Port)
SERIAL.print ("Current Magnitude: ™); Wio_Lite MG120
SERIAL.println({ams5€00.getMagnitude ()); . Seeeduina Wio lite MG126
break;

Crmnem Bl AT Fre CAdmm T mmmmas i o

Select the serial device of the Arduino board from the Tools | Serial Port menu. This is likely to be COM3 or
higher (COM1 and COM2 are usually reserved for hardware serial ports). To find out, you can disconnect your
Arduino board and re-open the menu; the entry that disappears should be the Arduino board. Reconnect the
board and select that serial port.

ITAttention You may not find the MG126 examples in the File > Examples tab before you select the wio Lite
MG126 board. When you select the board, the examples will appear here.

* Step 4. Open the demo

Click on File > Examples > Examples for Seeeduino Wio Lite MG126 > wio_lite_ble >example
>analog_output.
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File Edit Sketch Tools Help

Mew Ctrl+M

Open... Ctrl+ O

Open Recent

Sketchbook s

Examples s s

Close Crl+W 05.Control 5

kdefine DISELAY COLOR Oxd e armiriles fie Seerdinne Wi e G124

MG126_Ble Class MG126_Ble( 125 7
GroveTwoRGBLedMatrixClass SAMD_AnalogCorrection ’
vold setup() SOU 3
{
5PI »
SERIAL.begin({115200) : U5BHost ¥
delay {1000} ; Wio_lite_ble : example analog_output
SERIAL.println(™\ny :
>
SERIAL.println{"configur il bisiee
ini echo_ble
i i Examples from Custom Libraries -
) ) - get_bat_vol
Wire.begin({): Adafruit GFX Library

rgb_led_matrix_control

uintlé t VID = 0; Adafruit NecPixel >

= ; . serial_transparent_transmission
VID = matrix.getDe Adafruit 5GP30 Sensor > .
SERIAL.println (VID ; temp_humidity
o LT SR Adafruit 5501306 ¥

IAttention It is important to note that since the arduino IDE is temporarily incompatible with static libraries
(our Bluetooth protocol stack is compiled into a static library), the following configuration needs to be
changed when the example uses the Bluetooth library.

1. Open the file in the folder:

C:\Users\$(USER_NAME)\AppData\Local\Arduinol5\packages\Seeeduino\hardware\Seeeduin
0 Wio_Lite BLE\1.0.0\platform.txt

2. Go to line 75 and line 76

##trecipe.c.combine.pattern="{compiler.path}{compiler.c.elf.cmd}" "-L{build.path}"
{compiler.c.elf.flags} {compiler.c.elf.extra_flags} "-
T{build.variant.path}/{build.ldscript}" "-W1,-Map,
{build.path}/{build.project_name}.map" --specs=nano.specs --Specs=nosys.specs
{compiler.ldflags} -o "{build.path}/{build.project_name}.elf" {object_files} -WI1,-
-start-group {compiler.arm.cmsis.ldflags} -1m "{build.path}/{archive_file}" -W1,--
end-group

recipe.c.combine.pattern="{compiler.path}{compiler.c.elf.cmd}" "-L{build.path}"
{compiler.c.elf.flags} {compiler.c.elf.extra_flags} "-
T{build.variant.path}/{build.ldscript}" "-W1,-Map,
{build.path}/{build.project_name}.map" --specs=nano.specs --Specs=nosys.specs
{compiler.ldflags} -o "{build.path}/{build.project_name}.elf" {object_files}
{compiler.libraries.ldflags} -W1l,--start-group {compiler.arm.cmsis.ldflags} -1lm
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{build.path}/{archive_file}" -W1,--end-group

3. If the sample program has a Bluetooth library called, you need to add
comment the line), at the same time, you need to delete

9/27/2019

in front of line 75 (ie,
in front of line 76 (ie, uncomment).

Conversely, if the Bluetooth library is not called, but the basic operation of the SAM D21 development

board is used, the operation is reversed.

You can find 7 demos in this folder. The / demos do not use the bluetooth library, and

the rest do.

analog_output

button

echo_ble

get_bat_vol
rgb_led_matrix_control
serial_transparent_transrission

ternp_hurnidity

Demo Name

Function

Devicelnfo

analog_output

The analog value on the development board is
obtained via Bluetooth and displayed on the mobile

app.

Wio_BLE_Analog

Press onboard user button and print in the serial

button ]
monitor.
Bluetooth echo server, that is, the mobile phone o
echo_ble . Wio_Lite BLE
receives the data sent by the development board.
get_bat_vol Get the external battery voltage

rgb_led_matrix_control

Control the Grove - RGB LED Matrix to display

Wio_Led_matrix

serial_transparent_transmission

The serial port data is transparently transmitted, that
is, the data sent by the mobile phone will be sent
from the serial port of the development board, and
the data sent to the serial port of the development
board will be sent to the mobile phone.

Wio_Lite_Serial

temp_humidity

get the information from Grove - [2C High Accuracy
Temp&Humi Sensor (SHT35),and sent it to your
phone.

¢ Step 5. Upload the program

Wio_BLE_T&H

Now, simply click the "Upload" button in the environment. Wait a few seconds and if the upload is successful,

the message "Done uploading." will appear in the status bar.
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https://www.seeedstudio.com/Grove-RGB-LED-Matrix-w-Driver.html
https://www.seeedstudio.com/Grove-I2C-High-Accuracy-Temp-Humi-Sensor-SHT35.html
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&9 Blink | Arduino 1.6.9 - O X

File Edit Sketch Tools Help

When it is finished the information Done Uploading will Pop up in the lower left corner of Arduino IDE.
® Step 6. Use the phone to connect MG126

Open the nRF Connect app, click on the SCANNER and search for the name of the Devicelnfo in the page.
Different demos have different Devicelnfo, the and the corresponding Devicelnfo of analog_output is

So, please choose the in the bluetooth device list. Tap CONNECT, then click Automation 10
> Analog, and the value of AO pin will be displayed.

T4:01

=  Devices SCAN |

= Devices DISCOMNECT £ =  Devices DISCONNECT  §

SCANNER BONDED ADVERTISER PONDED ADVERTISER

Wi
ED

honoen ADVERTISER ~ WIO.BLEANALOG o WIO_BLE_ANALOG 3¢

BONDED
ki CONNECTED . CONNECTED

| i CLIENT  SERVER 1 s CLIENT  SERVER
° Wio_BLE_Analog .:. PEN TAB

ED:57:17:22:9ADA Generic Access Generic Access

NOT BONDED = 1D 0x1800 JUID: X1 800

PRIMARY SERVICE PRIMARY SERVICE

i"\il:zﬁb-m-as-aE-DF CONNECT Device Information Device Information

NOTBONDED 4 ' . - eipkee P8

N/A Automation 10 1 Automation 10 .
O JAGT2BFEARID LUIC: Dx1815 Cl IC k D 0x1815 Cl IC k

NOT BONDED PRIMARY SERVICE BEAMARY S ERune

Analog * Analog i

0 N/A CONNECT  } IUID: Dx2ASE UUID: Ox2ASE

08:0B:CASC4598 Fropesties: NOTIFY, READ Froperties: NOTIFY, READ

HOT BOMDED A Walse: (0x) 39, 9" Varlue: (0x) 31-30-32-33,"1023"

N/A COMMECT \

78:58:7 :E6F-BESE

NOTBONDED 4 A0 connect to GND, A0 connect to 3v3,

N/A Value 9 Value 1023

055 96-AAGE54

COWNECT 3
NOT BONDED A

IllAttention Due to the caching function of Bluetooth, every time you modify the feature value of Bluetooth
(that is, download the example using different Bluetooth functions), you need to clear the cache of the app
once, also you need to restart the phone.

Function interface
WiFi function interface

o 1. Bluetooth package class

MG126_Ble
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. 2. Initialize the Bluetooth protocol stack and turn on Bluetooth

MG126_Ble .ble_init();
. 3. Reporting messages via Bluetooth

sconn_notifydata();

Only some common interfaces are listed here, and other interfaces can view example.

Resouces
¢ [ZIP] Wio lite MG126 schematic files

¢ [PDF] DS-MG126-BLE-Datasheet

Tech Support

Please do not hesitate to submit the issue into our forum

() seeed:

Ncwikroduct
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https://github.com/SeeedDocument/Wio-Lite-MG126/raw/master/res/Wio%20Lite%20MG126.zip
https://github.com/SeeedDocument/Wio-Lite-MG126/raw/master/res/DS-MG126-BLE.pdf
https://forum.seeedstudio.com/
https://www.seeedstudio.com/act-4.html?utm_source=wiki&utm_medium=wikibanner&utm_campaign=newproducts

